Hoy me he encontrado con una de las conductas mas irresponsables que he visto en desarrollo de software.

Estos son los antecedentes.

WPML. Único software de traducción decente para wordpress. Software muy bueno, por cierto. Gratuito.
Wordpress. En las últimas versiones esta mejorando muchisimo, a todos los niveles.

En 2011, WPML deja de ser gratuito. De la noche a la mañana. Uno de los plugins mas utilizados por los usuarios de wordpress. La empresa desarrolladora informa que mantiene como gratuita hasta la version 2.0.4. Todas las siguientes versiones serán de pago. No se ofrece link de descarga de esa version y deja de funcionar la actualización automatica.

Aparece WordPress 3.1. No corrige ningun fallo de seguridad pero trae muchas funcionalidades nuevas. WPML 2.0.4 DEJA de funcionar correctamente. Miles de paginas web a tomar por saco.

Cientos de quejas a wpml.org. Respuesta oficial: la ultima version que se va a soportar de wordpress es la 3.0.5. Solucion: downgrade a wordpress 3.0.5. !!!!! WTF? Muchas mas quejas de los usuarios. Dos opciones: Quedarse anclados a wordpress 3.0.5 y wpml 2.0.4 para SIEMPRE, o comprar el software nuevo. El error esta definido. Es algo sencillo. Pero en los foros de wpml el tema es tabu, y toda pregunta sobre como solucionarlo es borrada y sustituida por un “compren”.

WPML responde que wordpress 3.0.5 es perfectamente funcional y no tiene problemas de seguridad. Y de nuevo que compremos.

Estado real en ese momento:
– la mayor parte de los wordpress con wpml NO funcionan.
– Algunas personas han comprado el plugin
– Muchas personas han abandonado wordpress como sistema multilenguaje
– Muchas personas han instalado el plugin de forma ilegal.

11 de abril de 2011. Actualizacion critica de wordpress. 3.1.1. Se solucionan 3 problemas de seguridad Graves. WordPress 3.0.5 ya NO es una opcion. WPML sigue diciendo que compres.

Estado real en este momento:

– La mayor parte de los wordpress con wmpl estan en 3.0.5, no pueden actualizar, y son vulnerables.
– La otra gran mayoria han actualizado y han dejado de funcionar.

Felicidades WPML por conseguir cabrear sin razon a una enorme cantidad de clientes potenciales, por forzar a la gente a comprar usando medidas absolutamente poco eticas, por ser unos irresponsables y dejar de mantener un codigo en el que la gente lleva 4 o 5 años confiando, y sobre todo por conseguir que la unica forma de usar su software sea convertir wordpress, que siempre habia sido bastante seguro, en un colador.

Ahora la solución que evita toda esta avalancha de mierda:

* Directorio del plugin, Fichero sitepress.class.php
* Ir a la linea 107
* Comentar la linea que dice //add_filter(‘term_link’, array($this, ‘tax_permalink_filter’),1,2);

Problema solucionado. Señores de wpml, ¿de verdad compensa cambiar 1000 usuarios contentos por 1 cliente y 999 usuarios cabreados y comprometer la seguridad de sus sitios? Por una ·$%$” modificacion que consiste en añadir dos barritas? Una modificacion que se peude hacer en 1 minuto de tiempo total, contando el conectarse al servidor, descargar el fichero, editarlo y volverlo a subir.

Claro que encontrar donde van las barritas han sido 3 horas de trabajo. Y si no eres desarrollador, no las vas a encontrar jamas.